Расчет суммы произведений в Excel

Содержание

Функция СУММПРОИЗВ для вычисления произведения суммы в Excel

Расчет суммы произведений в Excel

Функция СУММПРОИЗВ в Excel предназначена для нахождения произведения элементов с одинаковыми индексами двух или более констант массивов или двух и более диапазонов ячеек с числовыми данными, а также последующего суммирования полученных значений, и возвращает итоговую сумму.

Рассматриваемая функция может быть использована для нахождения суммы значений, соответствующих каким-либо критериям, которые указываются в качестве одного или нескольких аргументов данной функции в виде логических выражений.

Например, таблица состоит из трех полей данных с названиями «Товар», «Продавец», «Сумма покупки».

Чтобы определить общую средств, полученных на продаже товара товар_1 продавцом Продавец_1 можно использовать следующую формулу массива: =СУММПРОИЗВ(–(A1:A100=”товар_1”);–(B1:B100=”Продавец_1”);C1:C100), где A1:A100 – диапазон ячеек с названием товаров, B1:B100 – диапазон ячеек, в которых хранятся фамилии продавцов, C1:C100 – диапазон ячеек с числовыми значениями стоимости проданных товаров. Символы «–» – двойное отрицание, используемое для прямого преобразования логических ИСТИНА и ЛОЖЬ к числовым 1 и 0 соответственно. Подробнее эта формула будет рассмотрена в одном из примеров.



Пример 1. На склад поступили новые товары от 5 различных производителей по 20% от каждого, при этом 25% товаров первого поставщика – высшего качества, второго – 18%, третьего – 27%, четвертого – 55%, пятого – 5% соответственно. Определить вероятность того, что случайно выбранный товар окажется высшего качества.

Вид таблицы данных:

Для определения вероятности выбора товара высокого качества необходимо найти сумму произведений вероятностей, которые записаны в ячейки столбцов B:B и C:C соответственно. Для этого используем формулу:

Описание аргументов:

  • B2:B6 – первый диапазон ячеек с вероятностями выбора товаров 1-го, 2-го и т. д. производителей, значения которых будут умножены на соответствующие значения из второго диапазона;
  • C2:C6 – второй диапазон ячеек с вероятностями выбора товара высшего сорта среди товаров 1-го, 2-го и т. д. производителей соответственно.

В результате вычислений получаем следующее значение вероятности:

Как вычислить произведение суммы числ по условию в Excel?

Пример 2. В таблице хранятся данные о поставщиках, видах товаров и суммарной стоимости. Определить общую сумму закупок хлеба от первого поставщика без использования функции СУММЕСЛИМН.

Вид таблицы данных:

Для расчета используем формулу:

В качестве первого и второго аргументов функции переданы логически выражения, проверяющие на соответствие указанным значениям («хлеб», «поставщик_1») диапазоны ячеек A2:A17 и B2:B17 соответственно.

В результате выполнения этих выражений будут получены массивы логических значений ИСТИНА (если совпадение) и ЛОЖЬ, которые будут преобразованы в массивы числовых значений 1 или 0 благодаря использованию двойного отрицания «–». C2:C17 – диапазон ячеек со значениями стоимости.

В результате перемножения элементов и сложения произведений получим следующую суммарную закупочную стоимость хлеба от первого поставщика:

Расчет количества отклонений с помощью функции СУММПРОИЗВ в Excel

Пример 3. В цехе по производству деталей работают несколько работников определенного разряда, для каждого из которых установлена норма выработки за месяц. Определить число сотрудников третьего и выше разряда, не выполнивших свою месячную норму.

Вид таблицы данных:

Для расчета используем следующую формулу:

=СУММПРОИЗВ((НЕ(B2:B12>=C2:C12))*1;(D2:D12>2)*1)

Первый аргумент указан в виде логического выражения для сравнения значений в диапазонах, содержащих фактическую и требуемую продуктивности для каждого работника. Функция НЕ используется для возврата обратного значения. Второй аргумент указан в виде выражения для проверки разряда каждого сотрудника. Умножение на единицу выполняется для преобразования логических данных к числам.

В результате вычислений получим следующее число не выполнивших норму сотрудников:

Особенности использования функции СУММПРОИЗВ в Excel

Функция имеет следующий синтаксис:

=СУММПРОИЗВ(массив1;[массив2];[массив3];…)

Описание аргументов:

  • массив1 – обязательный аргумент, принимающий константу массива или диапазон ячеек с числовыми значениями, каждый элемент которого будет перемножен с соответствующим элементом (элементами) второго и последующих массивов или диапазонов, переданных в качестве последующих аргументов данной функции;
  • [массив2];[массив3];… – второй и последующие необязательные аргументы функции, принимающие константу массива или ссылку на диапазон ячеек, элементы которых будут перемножены с соответствующими элементами массивов или диапазонов (которые указаны в качестве предыдущих аргументов), а затем будет вычислена сумма произведений.

Примечания:

  1. Максимальное количество аргументов, принимаемых функцией СУММПРОИЗВ, составляет 255 диапазонов (или констант массивов).
  2. Если рассматриваемая функция принимает только один аргумент массив1, считается, что второй аргумент является массивом единиц, размерность которого соответствует размерности массив1. То есть, функции СУММ(A1:A10) и СУММПРОИЗВ(A1:10) вернут одинаковый результат.
  3. Если в качестве аргументов функции были переданы 2 и более константы массивов, они должны иметь одинаковую размерность (равно число элементов). Если в качестве аргументов СУММПРОИЗВ были переданы ссылки на 2 и более диапазона ячеек, эти диапазоны должны содержать одинаковое количество ячеек. При несоблюдении указанных условий функция СУМППРОИЗВ вернет код ошибки #ЗНАЧ!.
  4. Если в качестве аргументов функций были переданы константы массивов, содержащие нечисловые значения или ссылки на диапазоны ячеек с логическими ИСТИНА или ЛОЖЬ, не преобразуемые к числам строки или имена, функция СУММПРОИЗВ будет преобразовывать их числовому значению 0 (нуль). Например, если в одном столбце (A:A) содержатся названия товаров, а во втором (B:B) – их стоимость, функция =СУММПРОИЗВ(A1:A10;B1:B10) вернет значение 0, поскольку каждое значение в столбце A:A будет интерпретировано как число 0.

Источник: https://exceltable.com/funkcii-excel/primery-funkcii-summproizv

Как сделать сумму произведений в excel?

Расчет суммы произведений в Excel

При выполнении некоторых расчетов требуется находить сумму произведений. Этот вид вычислений часто выполняют бухгалтера, инженеры, планировщики, учащиеся образовательных учреждений.

Например, данный способ расчета востребован для сведения общего количества заработной платы за отработанные дни. Выполнение этого действия может понадобиться и в других отраслях, и даже для бытовых нужд.

Давайте выясним, как в программе Excel можно рассчитать сумму произведений.

Вычисление суммы произведения

Из самого наименования действия понятно, что сумма произведений представляет собой сложение результатов умножения отдельных чисел. В Экселе это действие можно выполнить с помощью простой математической формулы или применив специальную функцию СУММПРОИЗВ. Давайте рассмотрим подробно эти способы в отдельности.

Способ 1: использование математической формулы

Большинству пользователей известно, что в Экселе можно выполнить значительное количество математических действий просто поставив знак «=» в пустой ячейке, а далее записав выражение по правилам математики. Этот способ можно использовать и для нахождения суммы произведений. Программа, согласно математическим правилам, сразу подсчитывает произведения, а уже потом складывает их в общую сумму.

  1. Устанавливаем знак «равно» (=) в ячейке, в которой будет выводиться результат производимых вычислений. Записываем туда выражение суммы произведений по следующему шаблону:

    =a1*b1*…+a2*b2*…+a3*b3*…+…

    Например, таким способом можно рассчитать выражение:

    =54*45+15*265+47*12+69*78

  2. Чтобы произвести расчет и вывести его результат на экран, жмем на кнопку Enter на клавиатуре.

Способ 2: работа со ссылками

Вместо конкретных чисел в этой формуле можно указывать ссылки на ячейки, в которых они расположены. Ссылки можно вписать вручную, но удобнее это делать, выделив после знака «=», «+» или «*» соответствующую ячейку, в которой содержится число.

  1. Итак, сразу записываем выражение, где вместо чисел указаны ссылки на ячейки.
  2. Затем, чтобы произвести подсчет, кликаем по кнопке Enter. Результат вычисления будет выведен на экран.

Конечно, данный вид вычисления довольно простой и интуитивно понятный, но в случае, если в таблице очень много значений, которые нужно перемножить, а потом сложить, этот способ может занять очень много времени.

Урок: Работа с формулами в Excel

Способ 3: использование функции СУММПРОИЗВ

Для того, чтобы подсчитать сумму произведения, некоторые пользователи предпочитают специально предназначенную для этого действия функцию – СУММПРОИЗВ.

Наименование данного оператора говорит о его предназначении само за себя. Преимущество этого способа перед предыдущим состоит в том, что с его помощью можно обрабатывать сразу целые массивы, а не выполнять действия с каждым числом или ячейкой в отдельности.

Синтаксис данной функции имеет такой вид:

=СУММПРОИЗВ(массив1;массив2;…)

Аргументами этого оператора являются диапазоны данных. При этом они сгруппированы по группам множителей.

То есть, если отталкиваться от шаблона, о котором мы говорили выше (a1*b1*…+a2*b2*…+a3*b3*…+…), то в первом массиве располагаются множители группы a, во втором – группы b, в третьем – группы c и т.д.

Данные диапазоны обязательно должны быть однотипными и равными по длине. Располагаться они могут, как вертикально, так и горизонтально. Всего данный оператор может работать с количеством аргументов от 2 до 255.

Формулу СУММПРОИЗВ можно сразу записывать в ячейку для вывода результата, но многим пользователям легче и удобнее производить вычисления через Мастер функций.

  1. Выделяем ячейку на листе, в которой будет выводиться итоговый результат. Жмем на кнопку «Вставить функцию». Она оформлена в виде пиктограммы и располагается слева от поля строки формул.
  2. После того, как пользователь произвел данные действия, запускается Мастер функций. В нем открывается список всех, за малым исключением, операторов, с которыми можно работать в Экселе. Чтобы найти нужную нам функцию, переходим в категорию «Математические» или «Полный алфавитный перечень». После того, как нашли наименование «СУММПРОИЗВ», выделяем его и жмем на кнопку «OK».
  3. Запускается окно аргументов функции СУММПРОИЗВ. По количеству аргументов оно может иметь от 2 до 255 полей. Адреса диапазонов можно вбивать вручную. Но это займет значительное количество времени. Можно сделать несколько по-другому. Устанавливаем курсор в первое поле и выделяем с зажатой левой кнопкой мыши массив первого аргумента на листе. Таким же образом поступаем со вторым и со всеми последующими диапазонами, координаты которых сразу же отображаются в соответствующем поле. После того, как все данные введены, жмем на кнопку «OK» в нижней части окна.
  4. После этих действий программа самостоятельно производит все требуемые вычисления и выводит итоговый результат в ту ячейку, которая была выделена в первом пункте данной инструкции.

Урок: Мастер функций в Excel

Способ 4: применение функции по условию

Функция СУММПРОИЗВ хороша и тем, что её можно применять по условию. Разберем, как это делается на конкретном примере.

У нас есть таблица окладов и отработанных дней работников предприятия за три месяца помесячно. Нам нужно узнать, какую сумму на протяжении этого периода заработал сотрудник Парфенов Д.Ф.

  1. Тем же способом, что и в предыдущий раз, вызываем окно аргументов функции СУММПРОИЗВ. В первых двух полях указываем в качестве массивов соответственно диапазоны, где указана ставка сотрудников и количество отработанных ими дней. То есть, делаем все, как и в предыдущем случае. А вот в третьем поле задаем координаты массива, в котором содержатся имена сотрудников. Сразу же после адреса добавляем запись:

    =”Парфенов Д.Ф.”

    После того, как все данные внесены, жмем кнопку «OK».

  2. Приложение производит вычисление. В расчет берутся только строчки, в которых присутствует имя «Парфенов Д.Ф», то есть то, что нам и нужно. Результат вычислений отображается в предварительно выделенной ячейке. Но результат равен нулю. Это связано с тем, что формула в том виде, в котором она существует сейчас, работает некорректно. Нам нужно её немного преобразовать.
  3. Для того чтобы преобразовать формулу, выделяем ячейку с итоговым значением. Выполняем действия в строке формул. Аргумент с условием берем в скобки, а между ним и другими аргументами точку с запятой меняем на знак умножения (*). Жмем на кнопку Enter. Программа производит подсчет и на этот раз выдает уже корректное значение. Мы получили общую сумму заработной платы за три месяца, которая причитается сотруднику предприятия Парфенову Д. Ф.

Таким же образом можно применять условия не только к тексту, но и к числам с датами, добавляя знаки условия «», «=», «< >».

Как видим, существует два основных способа вычисления суммы произведений. Если данных не слишком много, то легче воспользоваться простой математической формулой.

Когда же в вычислении участвует большое количество чисел, пользователь сбережет значительное количество своего времени и сил, если воспользуется возможностями специализированной функции СУММПРОИЗВ.

Кроме того, с помощью этого же оператора можно производить вычисление по условию, что обычная формула не умеет делать.

Мы рады, что смогли помочь Вам в решении проблемы.

Источник: http://word-office.ru/kak-sdelat-summu-proizvedeniy-v-excel.html

Расчет суммы произведений в Excel

Расчет суммы произведений в Excel

При выполнении некоторых расчетов требуется находить сумму произведений. Этот вид вычислений часто выполняют бухгалтера, инженеры, планировщики, учащиеся образовательных учреждений.

Например, данный способ расчета востребован для сведения общего количества заработной платы за отработанные дни. Выполнение этого действия может понадобиться и в других отраслях, и даже для бытовых нужд.

Давайте выясним, как в программе Excel можно рассчитать сумму произведений.

Скачать последнюю версию Excel

Помогла ли вам эта статья?

ДА НЕТ

Источник: http://lumpics.ru/the-sum-of-products-in-excel/

Как вычислить сумму произведений в Excel с помощью встроенной функции?

Расчет суммы произведений в Excel

Времена, когда бухгалтеры рассчитывали заработную плату при помощи ручных счет или калькулятора с минимальным набором функций и огромными кнопками, канули в небытие.

На сегодняшний день все экономические и бухгалтерские расчеты производятся с использованием программных средств, есть множество специализированного программного обеспечения, которое позволяет выполнять работу в автоматическом режиме.

Но иногда возникает необходимость выполнить какие-либо вычисления, не предусмотренные программным обеспечением, используемым работодателем. Тогда на помощь приходят всем знакомые средства Microsoft Office.

Microsoft Excel – это один из основных инструментов для работы с цифрами и массивами чисел, для сортировки и выборки записей, анализа данных, составления планов и диаграмм.

В указанном пакете имеется ряд встроенных функций, которые позволяют выполнять вычисления в автоматическом режиме.

Функции позволяют значительно упростить формулы, которые используются в электронной таблице Excel, для того чтобы документ не был перегружен длинными формулами и вычислениями. Ознакомиться с полным перечнем встроенных функций в Excel можно, используя справку Microsoft Office.

Одна из множества полезных функций, которые помогают работать с многомерными массивами данных и матричным вычислениям в Excel, – сумма произведений.

Встроенные функции в Excel расширяют основные возможности системы, и для того, чтобы просмотреть весь перечень указанных возможностей, можно просто воспользоваться значком fx, расположенным перед строкой формул (белая строка, в которой набираются символы при заполнении ячеек в Excel).

После нажатия значка fx появится окно «Мастера функций». Следуя его подсказкам, можно выбрать подходящую функцию и получить краткую информацию по работе с ней. При этом можно использовать несколько вариантов поиска функции:

  1. Применить фильтр и установить категорию функции для облегчения поиска необходимой формулы, которая позволит сделать необходимые вычисления. Сумма произведений в Excel входит в категорию «Математические».
  2. Использовать поиск по названию (этот вариант подойдет только в том случае, если известно название необходимой функции в Excel). В окне «Поиск функции» необходимо набрать название и нажать кнопку «Поиск», система сама найдет названия встроенных функций, соответствующие введенному запросу. Для того, чтобы вычислить сумму произведений чисел из заданных массивов, в окне поиска следует набрать название функции – «СУММПРОИЗВ».

Для того, чтобы воспользоваться встроенной функцией, необходимо выбрать ее курсором и нажать кнопку ОК в окне «Мастера функций». После выполнения указанных действий появится окно «Аргументы функции», в котором необходимо будет указать все требуемые параметры.

В случае, если название функции заведомо известно, и пользователю не нужны дополнительные подсказки по ее использованию, можно просто поставить в строке формул знак равно (=) и ввести название встроенной функции. При этом необходимо помнить, что помимо названия потребуется ввести еще и аргументы заданной функции Excel.

Аргументы функции для вычисления суммы произведений

Функция для вычисления суммы произведений чисел из заданных массивов определяет итог выполнения определенных действий со значениями, которые используются в качестве аргументов функции.

При этом в качестве аргументов могут выступать значения различных типов, а система подскажет пользователю необходимый.

Формула суммы произведений в Excel перемножает соответствующие значения из указанных массивов (в качестве массивов используются определенные строки или столбцы) и возвращает сумму произведений значений, приведенных в массивах.

Синтаксис функции и разделительные знаки

Для того, чтобы встроенные функции работали корректно, следует четко соблюдать установленный для них синтаксис (то есть использовать стандартные знаки разделения между аргументами функции).

Функция для вычисления суммы произведений имеет следующий синтаксис – «СУММПРОИЗВ(массив1,массив2,массив3,…)».

То есть для корректных вычислений следует применять скобки и запятые, а для указания начальных и конечных ячеек с массивами в качестве разделителя использовать двоеточие (:).

При этом в качестве аргументов могут выступать значения, которые предоставляют информацию для события, действия, метода, свойства, функции или процедуры. Массив 1 является обязательным аргументом для вышеуказанной функции, а последующие массивы задаются, исходя из необходимости.

Количество необязательных массивов (компоненты которых будут перемножаться для дальнейшего суммирования) может составлять от 2 до 255.

Пример применения функции для вычисления суммы произведений

Для наглядности использования функции СУММПРОИЗВ следует рассмотреть следующий пример:

  1. Заполним ячейки в таблице Excel как показано на рисунке, приведенном ниже.
  2. В строке формул запишем «СУММПРОИЗВ(A2:B5;C2:D5)». Для того, чтобы начать вводить в ячейку какую-либо функцию, следует поставить в ней знак равно, а затем записать корректное название встроенной функции и все необходимые аргументы.
  3. Нажмем клавишу ввода (Enter).

При этом в ячейке, для которой набиралась формула, Excel выведет результат вычислений. В указанном случае это будет число 9290. Система при этом выполнила следующие арифметические операции:

1×100+3×500+5×230+6×250+2×250+4×130+9×400+2×210=9290.

Ошибки при использовании функции

Самыми распространенными ошибками при использовании встроенных в Excel функций являются:

  1. Использование некорректного синтаксиса (лишний пробел между знаками или запятая, поставленная вместо двоеточия, способны привести к ошибкам работе функции).
  2. Аргументы, которые используются в качестве массивов в указанной функции, должны иметь одинаковую размерность. Если не следовать данному совету, то функция будет работать некорректно и возвратит в ячейку значение ошибки (#ЗНАЧ!).
  3. Если в качестве значений в массивах использовать нечисловые элементы, то они воспринимаются функцией СУММПРОИЗВ как нулевые и могут привести к некорректному конечному результату вычислений.

Не бойтесь использовать возможности Microsoft Excel по максимуму, и тогда он станет вашим надежным помощником в рутинной работе! Многим пользователям кажется, что вычисление суммы произведений в Excel им никогда не понадобится, но когда они начинают использовать возможности программы в своей работе, то этот функционал оказывается довольно полезным.

Источник: http://fb.ru/article/393374/kak-vyichislit-summu-proizvedeniy-v-excel-s-pomoschyu-vstroennoy-funktsii

Как в Excel посчитать сумму в столбце: все способы

Расчет суммы произведений в Excel

Excel – мощный редактор для работы с большим объемом данных и ведения различных расчётов при помощи формул. Но как правило, не каждый пользователь знает про все возможности, которые есть в этой программе.

Например, как в Excel посчитать сумму в столбце. Некоторые по незнанию используют для этого калькулятор. В данной статье будут рассмотрены различные формулы, которые могут пригодиться большинству офисных работников.

Автосуммирование

Для демонстрации возможностей этой функции, нужно будет сделать следующие действия.

  1. Первым делом следует создать какую-нибудь простую таблицу с несколькими значениями. Разместим их всех в один столбик.
  1. Затем выделите все ячейки. После этого нажмите на иконку «Суммы», расположенную в правой части панели инструментов.
  1. В результате этого редактор автоматически посчитает сумму и выведет ее на следующей строке.

Для того чтобы вывести итоговый результат в отдельном месте, нужно сделать немного иные действия.

  1. Кликните на какую-нибудь ячейку.
  2. Снова нажмите на иконку «Суммы».
  1. В результате этого Эксель предложит сосчитать всё то, что находится выше. Но там ведь находятся и пустые ячейки.
  1. Поэтому выделяем только те, которые нам нужны, иначе будут считаться и пустые значения (в момент выделения ваш курсор примет вид белого крестика).
  1. Для того чтобы изменения вступили в силу, нужно нажать на клавиатуре на клавишу Enter.

Строка состояния

Существует еще один очень простой способ. Узнать общую сумму значений в ячейках можно обычным выделением. Как только вы это сделаете, результат отобразится в строке состояния, расположенной в нижней части программы.

Кроме этого, мы увидим количество элементов и их среднее значение.

Минус данного метода в том, что результат сложения на листе нигде не выводится.

Использование функций

Найти сумму цифр в ячейках можно и при помощи формул. Делается это следующим образом.

  1. Кликните на какую-нибудь ячейку.
  2. Перейдите в строку ввода уравнений.
  1. Введите там следующий текст.

=СУММ(

  1. В результате этого у вас появится подсказка, что дальше нужно вводить числа.
  1. Укажите там диапазон ячеек, в которых находятся значения. Вводить нужно сначала букву, а потом цифру.
  1. Либо вы можете просто выделить эти ячейки.
  1. В итоге должно получиться следующее.

=СУММ(C4:C9)

  1. Далее нажмите на клавиатуре на клавишу Enter. Только после этого вы сможете узнать результат.

Преимущество данного метода в том, что вы можете вручную указывать выборочный диапазон ячеек.

Суммирование произведений двух столбцов

Иногда на практике нужно вывести не просто сумму, но еще сделать дополнительные математические действия в разных колонках. Например, как в представленном случае.

Для вывода общей суммы необходимо сделать следующие действия.

  1. Сделайте активной нужную ячейку.
  2. Кликните на строку ввода формулы.
  1. Напишите следующую команду.

=СУММ(

  1. Выделите вручную значения в одной из колонок. Например, в нашем случае выделим столбец «Количество».

Если в формуле автоматически не появится закрывающая скобка, ее нужно будет добавить вручную.

  1. Затем сдвигаемся в формуле правее и ставим символ «*» (знак умножения). Если вы работаете на ноутбуке, то нужно будет нажать на сочетание клавиш Shift+8.
  1. После этого пишем еще раз следующий код.

=СУММ(

  1. На этот раз выделяем другой столбец.
  1. Обязательно проверяем наличие закрывающей скобки.

Для завершения нужно нажать на клавишу Enter. В результате этого вы увидите сумму произведения двух столбцов.

Сумма с одним условием

Так же бывают случаи, когда нужно складывать не всё подряд, а лишь некоторую часть ячеек. Для этого нужно использовать дополнительные условия, которые будут служить аналогом фильтра значений.

Проверку можно делать как по числовому, так и по текстовому формату данных. Рассмотрим оба случая.

Текстовое значение

  1. Для начала добавим в таблице новую строку для вычислений.
  1. Перейдите в нужную ячейку. Затем кликните на строку ввода формул.
  1. Введите там следующую команду.

=СУММЕСЛИ(

  1. В результате этого редактор Excel выведет вам подсказку, что нужно сначала указать диапазон значений, затем критерий отбора и в конце сам диапазон суммирования.
  1. Выделяем сначала колонку, по которой будем делать проверку.

    В нашем случае это столбец «Статус», в котором есть два состояния – «пусто» и «продано».

  1. После выделения обязательно добавляем символ «;» (точка с запятой), иначе будет ошибка в формуле. Затем пишем слово, по которому будем делать фильтр. В нашем случае это «Продано». Писать необходимо в кавычках.

    Это обязательно. Разумеется, после этого снова ставим символ «;».

  1. Теперь выделяем тот столбец, по которому будут происходить расчеты.
  1. Добавляем закрывающую скобку «)».
  1. Для проверки работы формулы нажимаем на клавиатуре на клавишу Enter.

    В результате описанных выше действий должны посчитаться значения только тех ячеек, напротив которых написано слово «Продано».

Это очень удобно, особенно если в вашем отчете огромное количество информации.

Численное значение

В этом случае для проверки будем использовать графу «Стоимость». Для расчета выполним следующие действия.

  1. Добавим еще одну строку, в которой будем выводить «Количество дорогих товаров».
  1. Перейдите в нужную ячейку. После этого начните вводить эту же функцию.

=СУММЕСЛИ(

  1. В качестве условия выделяем столбец «Стоимость».
  1. Обязательно дописываем символ «;». Только после этого можно будет перейти к следующему аргументу.
  1. Затем в кавычках указываем «>20». Это условие означает – считать всё то, что больше 20. Здесь используются обычные математические операторы – всё как в школе. В конце снова ставим символ «;».
  1. Только теперь можно указать столбец, в котором будут производиться расчёты.
  1. Ставим закрывающую скобку «)».
  1. Для проверки результата нажимаем на клавиатуре кнопку Enter.

Благодаря этому мы смогли найти количество всех дорогих товаров. Таким же способом можно посчитать что угодно. Всё зависит от условия.

Сумма с несколькими условиями

Но иногда всё намного сложней. Например, могут быть случаи, когда нужно посчитать в столбце сумму всех одновременно и дорогих, и проданных продуктов. Рассмотрим, как правильно составить формулу для этой ситуации.

  1. Сначала добавим новую строку.
  1. Выделяем нужную ячейку и переходим в строку ввода функций.
  1. На этот раз вводим другую формулу.

=СУММЕСЛИМН(

Буквы МН означают, что будет использовано много условий.

У этой функции аргументы расположены в ином порядке (в отличие от СУММЕСЛИ).

  1. Здесь мы сразу выделяем тот столбец, в котором указано количество товаров. В прошлый раз мы это делали в последнюю очередь – здесь всё наоборот.
  1. Обязательно закрываем аргумент точкой с запятой. Затем смотрим на подсказку, что делать дальше.
  1. Указываем диапазон первого условия. В нашем случае это графа «Стоимость».
  1. Для того чтобы не было ошибок, дописываем символ «;». Затем в двойных кавычках пишем условие сортировки. Например, в нашем случае это «>20». Также закрываем точкой с запятой. Если вы часто работаете в Excel или планируете там работать – нужно привыкать все аргументы закрывать этим символом.
  1. Далее мы видим подсказку, что нужно проделать те же самые действия, но теперь для второго условия. Их может быть огромное количество. Просто каждый раз необходимо выделять нужный диапазон и затем указывать условие. Выделяем столбец «Статус».
  1. Ставим точку с запятой и пишем в кавычках слово «Продано». В конце нашей формулы обязательно ставим закрывающую скобку.

Для завершения работы с редактором функций нажмите на клавишу Enter. Сразу после этого вы увидите результат.

В нашем случае мы видим, что дорогих товаров у нас 18, а продано из них всего 10.

Заключение

В данной статье были рассмотрены основные возможности редактора Excel для расчета суммы значений в столбцах:

  • через панель инструментов;
  • обычное сложение при помощи одной функции;
  • с учетом одного условия;
  • применение сложных формул.

Если у вас что-то не получилось, возможно вы делаете что-то не так. Большой процент ошибок многие допускают именно из-за синтаксиса, то есть забывают дописывать кавычки или скобки.

инструкция

Если у вас что-то не получилось или остались какие-нибудь вопросы, ниже прилагается видеоролик, в котором можно увидеть дополнительные замечания к описанным выше инструкциям.

Источник: https://os-helper.ru/excel/kak-poschitat-summu-znachenij-stolbca.html

Функция СУММПРОИЗВ() – Сложение и подсчет с множественными условиями в MS EXCEL

Расчет суммы произведений в Excel

Функция СУММПРОИЗВ(), английская версия SUMPRODUCT(), не так проста, как кажется с первого взгляда: помимо собственно нахождения суммы произведений, эта функция может использоваться для подсчета и суммирования значений на основе критериев, а также, в некоторых случаях, избавить от необходимости применений формул массива.

Существует несколько вариантов применения функции СУММПРОИЗВ():

  • нахождение суммы произведений элементов списка (массива);
  • суммирование и подсчет значений, удовлетворяющих определенным критериям;
  • замена формул массива (в некоторых случаях).

Нахождение суммы произведений элементов массивов

В этом разделе показан синтаксис функции СУММПРОИЗВ()и раскрыт ее потенциал для других применений.

Пусть имеется 2 диапазона чисел A3:A6 и B3:B6, содержащие соответственно 2 массива чисел: {4:8:6:1} и {7:6:7:5}. Записав формулу =СУММПРОИЗВ(A3:A6;B3:B6), получим 123.

Результат получен поэлементным перемножением всех элементов двух массивов, а затем сложением полученных произведений.

То есть были выполнены следующие арифметические действия: 4*7 + 8*6 + 6*7 + 1*5= 123

Таким образом, можно найти сумму произведений 3-х, 4-х и т.д. массивов.

Аргументы, которые являются массивами, должны иметь одинаковые размерности (в нашем случае это массивы по 4 элемента). В противном случае функция СУММПРОИЗВ() возвращает значение ошибки #ЗНАЧ!.

В формуле =СУММПРОИЗВ(A3:A6;B3:B6) функция СУММПРОИЗВ() трактует нечисловые элементы массивов как нулевые. Однако, как показано ниже, функцию можно использовать для подсчета текстовых значений.

Что произойдет если указать только 1 массив, т.е.=СУММПРОИЗВ(A3:A6)? Тогда функция СУММПРОИЗВ() вернет сумму элементов, т.е. будет эквивалентна функции СУММ(): =СУММ(A3:A6).

Синтаксис функции СУММПРОИЗВ() позволяет не просто указывать в качестве аргумента определенный диапазон, но и осуществлять арифметические действия перед операцией суммирования. Например, записав:

  • =СУММПРОИЗВ(A3:A6*2), получим сумму произведений =38 (каждый элемент массива из A3:A6 был умножен на 2, затем все произведения просуммированы);
  • =СУММПРОИЗВ(A3:A6*B3:B6), получим результат суммы произведений – 123 (все элементы массивов были попарно перемножены, а затем сложены, т.е. A3*B3+ A4*B4+ A5*B5+ A6*B6), т.е. эта запись эквивалента формула =СУММПРОИЗВ(A3:A6;B3:B6);
  • =СУММПРОИЗВ(A3:A6+B3:B6), получим сумму элементов из двух диапазонов;
  • =СУММПРОИЗВ(A3:A6/B3:B6), получим сумму попарных отношений всех элементов,  т.е. 4/7 + 8/6 + 6/7 + 1/5= 2,9619

Аналогичные вычисления можно выполнить и с функцией СУММ(), только для этого нужно ее ввести как формулу массива, т.е. после ввода функции в ячейку вместо ENTER нажать CTRL+SHIFT+ENTER: =СУММ(A3:A6/B3:B6)

Прелесть функции СУММПРОИЗВ() в том, что после ввода функции в ячейку можно просто нажать ENTER, что снимает некий психологический барьер перед использованием формул массива.

Оказывается, что в качестве аргумента этой функции можно указать не только произведение массивов (A3:A6*B3:B6), но и использовать другие функции и даже применить к массивам операции сравнения, т.е. использовать ее для сложения чисел, удовлетворяющих определенным условиям.

Суммирование и подсчет значений удовлетворяющих определенным критериям

Попробуем подсчитать число значений больших 2 в диапазоне A3:A6, содержащий значения 4, 8, 6, 1.

Если мы запишем формулу =СУММПРОИЗВ(A3:A6>2), то получим результат 0.

Выделив в Строке формул A3:A6>2 и нажав клавишу F9, получим массив {ИСТИНА: ИСТИНА: ИСТИНА: ЛОЖЬ}, который говорит, что мы движемся в правильном направлении: в диапазоне A3:A6 больше 2 только первые 3 значения.

Хотя значению ИСТИНА соответствует 1, а ЛОЖЬ – 0, мы не получим 3, т.к. для перевода значений ИСТИНА/ЛОЖЬ в числовую форму требуется применить к ним арифметическую операцию. Для этого можно, например, применить операцию двойного отрицания (–), что позволит привести массив в числовую форму {1:1:1:0}.

Итак, задача подсчета значений больше 2 решается следующим образом: =СУММПРОИЗВ(–(A3:A6>2))

Вместо двойного отрицания можно использовать другие формулы: =СУММПРОИЗВ(1*(A3:A6>2)) или =СУММПРОИЗВ(0+(A3:A6>2)) или даже так  =СУММПРОИЗВ((A3:A6>2)1).

Запись >2 является критерием, причем можно указать любые операции сравнения (G8)) – ячейка G8 должна содержать число 2.

Критерии можно применять и к текстовым значениям, например, =СУММПРОИЗВ(–(B3:B6=”яблоки”)) – вернет количество ячеек, содержащие слово яблоки (подробнее, например, в статье Подсчет значений с множественными критериями (Часть 1. Условие И)).

Функцию СУММПРОИЗВ() можно использовать для отбора значений по нескольким критериям (с множественными условиями). Как известно, 2 критерия могут образовывать разные условия:

  • Условие ИЛИ. Например, подсчитать ячеек содержащих значение яблоки ИЛИ груши =СУММПРОИЗВ((B3:B6=”яблоки”)+(B3:B6=”груши”));
  • Условие И. Например, подсчитать количество значений больше 2 и меньше 5: =СУММПРОИЗВ((A3:A6>2)*(A3:A62)*(A3:A6

Источник: https://excel2.ru/articles/funkciya-summproizv-slozhenie-i-podschet-s-mnozhestvennymi-usloviyami-v-ms-excel-summproizv

Поделиться:
Нет комментариев

    Добавить комментарий

    Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.