Решение системы уравнений в Microsoft Excel

Содержание

Решение уравнений в Excel методом итераций Крамера и Гаусса

Решение системы уравнений в Microsoft Excel

В программе Excel имеется обширный инструментарий для решения различных видов уравнений разными методами.

Рассмотрим на примерах некоторые варианты решений.

Инструмент «Подбор параметра» применяется в ситуации, когда известен результат, но неизвестны аргументы. Excel подбирает значения до тех пор, пока вычисление не даст нужный итог.

Путь к команде: «Данные» – «Работа с данными» – «Анализ «что-если»» – «Подбор параметра».

Рассмотрим на примере решение квадратного уравнения х2 + 3х + 2 = 0. Порядок нахождения корня средствами Excel:

  1. Введем в ячейку В2 формулу для нахождения значения функции. В качестве аргумента применим ссылку на ячейку В1.
  2. Открываем меню инструмента «Подбор параметра». В графе «Установить в ячейку» – ссылка на ячейку В2, где находится формула. В поле «Значение» вводим 0. Это то значение, которое нужно получить. В графе «Изменяя значение ячейки» – В1. Здесь должен отобразиться отобранный параметр.
  3. После нажатия ОК отобразится результат подбора. Если нужно его сохранить, вновь нажимаем ОК. В противном случае – «Отмена».

Для подбора параметра программа использует циклический процесс. Чтобы изменить число итераций и погрешность, нужно зайти в параметры Excel. На вкладке «Формулы» установить предельное количество итераций, относительную погрешность. Поставить галочку «включить итеративные вычисления».



Дана система уравнений:

  1. Значения элементов введем в ячейки Excel в виде таблицы.
  2. Найдем обратную матрицу. Выделим диапазон, куда впоследствии будут помещены элементы матрицы (ориентируемся на количество строк и столбцов в исходной матрице). Открываем список функций (fx). В категории «Математические» находим МОБР. Аргумент – массив ячеек с элементами исходной матрицы.
  3. Нажимаем ОК – в левом верхнем углу диапазона появляется значение. Последовательно жмем кнопку F2 и сочетание клавиш Ctrl + Shift + Enter.
  4. Умножим обратную матрицу Ах-1х на матрицу В (именно в таком порядке следования множителей!). Выделяем диапазон, где впоследствии появятся элементы результирующей матрицы (ориентируемся на число строк и столбцов матрицы В). Открываем диалоговое окно математической функции МУМНОЖ. Первый диапазон – обратная матрица. Второй – матрица В.
  5. Закрываем окно с аргументами функции нажатием кнопки ОК. Последовательно нажимаем кнопку F2 и комбинацию Ctrl + Shift + Enter.

Получены корни уравнений.

Решение системы уравнений методом Крамера в Excel

Возьмем систему уравнений из предыдущего примера:

Для их решения методом Крамера вычислим определители матриц, полученных заменой одного столбца в матрице А на столбец-матрицу В.

Для расчета определителей используем функцию МОПРЕД. Аргумент – диапазон с соответствующей матрицей.

Рассчитаем также определитель матрицы А (массив – диапазон матрицы А).

Определитель системы больше 0 – решение можно найти по формуле Крамера (Dx / |A|).

Для расчета Х1: =U2/$U$1, где U2 – D1. Для расчета Х2: =U3/$U$1. И т.д. Получим корни уравнений:

Решение систем уравнений методом Гаусса в Excel

Для примера возьмем простейшую систему уравнений:

3а + 2в – 5с = -12а – в – 3с = 13

а + 2в – с = 9

Коэффициенты запишем в матрицу А. Свободные члены – в матрицу В.

Для наглядности свободные члены выделим заливкой. Если в первой ячейке матрицы А оказался 0, нужно поменять местами строки, чтобы здесь оказалось отличное от 0 значение.

  1. Приведем все коэффициенты при а к 0. Кроме первого уравнения. Скопируем значения в первой строке двух матриц в ячейки В6:Е6. В ячейку В7 введем формулу: =B3:Е3-$B$2:$Е$2*(B3/$B$2). Выделим диапазон В7:Е7. Нажмем F2 и сочетание клавиш Ctrl + Shift + Enter. Мы отняли от второй строки первую, умноженную на отношение первых элементов второго и первого уравнения.
  2. Копируем введенную формулу на 8 и 9 строки. Так мы избавились от коэффициентов перед а. Сохранили только первое уравнение.
  3. Приведем к 0 коэффициенты перед в в третьем и четвертом уравнении. Копируем строки 6 и 7 (только значения). Переносим их ниже, в строки 10 и 11. Эти данные должны остаться неизменными. В ячейку В12 вводим формулу массива.
  4. Прямую прогонку по методу Гаусса сделали. В обратном порядке начнем прогонять с последней строки полученной матрицы. Все элементы данной строки нужно разделить на коэффициент при с. Введем в строку формулу массива: {=B12:E12/D12}.
  5. В строке 15: отнимем от второй строки третью, умноженную на коэффициент при с второй строки ({=(B11:E11-B16:E16*D11)/C11}). В строке 14: от первой строки отнимаем вторую и третью, умноженные на соответствующие коэффициенты ({=(B10:E10-B15:E15*C10-B16:E16*D10)/B10}). В последнем столбце новой матрицы получаем корни уравнения.

Примеры решения уравнений методом итераций в Excel

Вычисления в книге должны быть настроены следующим образом:

Делается это на вкладке «Формулы» в «Параметрах Excel». Найдем корень уравнения х – х3 + 1 = 0 (а = 1, b = 2) методом итерации с применением циклических ссылок. Формула:

Хn+1 = Xn– F (Xn) / M, n = 0, 1, 2, … .

M – максимальное значение производной по модулю. Чтобы найти М, произведем вычисления:

f’ (1) = -2 * f’ (2) = -11.

Полученное значение меньше 0. Поэтому функция будет с противоположным знаком: f (х) = -х + х3 – 1. М = 11.

В ячейку А3 введем значение: а = 1. Точность – три знака после запятой. Для расчета текущего значения х в соседнюю ячейку (В3) введем формулу: =ЕСЛИ(B3=0;A3;B3-(-B3+СТЕПЕНЬ(B3;3)-1/11)).

В ячейке С3 проконтролируем значение f (x): с помощью формулы =B3-СТЕПЕНЬ(B3;3)+1.

Корень уравнения – 1,179. Введем в ячейку А3 значение 2. Получим тот же результат:

Скачать решения уравнений в Excel

Корень на заданном промежутке один.

Источник: https://exceltable.com/otchety/reshenie-uravneniy

Решение систем линейных алгебраических уравнений в Excel

Решение системы уравнений в Microsoft Excel
Методы решения систем линейных алгебраических уравнений хорошо описаны в учебнике “Основы вычислительной математики. Демидович Б.П., Марон И.А. 1966”.

Скачать – 11Мб

Если дано уравнение: A*X = B, где A – квадратная матрица, X,B – вектора; причем B – известный вектор (т е столбец чисел), X – неизвестный вектор, то решение X можно записать в виде:

X = A-1*B, где A-1 – обратная от А матрица.

В MS Excel обратная матрица вычисляется функцией МОБР(), а перемножаются матрицы (или матрица на вектор) – функцией МУМНОЖ().

Имеются “тонкости” использования этих матричных действий в Excel. Так, чтобы вычислить обратную матрицу от матрицы А, нужно: 1. Мышкой выделить квадратную область клеток, где будет размещена обратная матрица. 2. Начать вписывать формулу =МОБР( 3. Выделить мышкой матрицу А. При этом правее скобки впишется соответствующий диапазон клеток. 4.

Закрыть скобку, нажать комбинацию клавиш: Ctrl-Shift-Enter 5. Должна вычислиться обратная матрица и заполнить предназначенную для неё область Чтобы умножить матрицу на вектор: 1. Мышкой выделить область клеток, где будет размещён результат умножения 2. Начать вписывать формулу =МУМНОЖ( 3. Выделить мышкой матрицу – первый сомножитель.

При этом правее скобки впишется соответствующий диапазон клеток. 4. С клавиатуры ввести разделитель ; (точка с запятой) 5. Выделить мышкой вектор- второй сомножитель. При этом правее скобки впишется соответствующий диапазон клеток. 6. Закрыть скобку, нажать комбинацию клавиш: Ctrl-Shift-Enter 7.

Должно вычислиться произведение и заполнить предназначенную для него область Есть и другой спососб, при котором используется кнопка построителя функции Excel.

Пример СЛАУ 4-го порядка

Скачать документ Excel, в котором этот пример решён различными методами.

2. Метод Гаусса

Метод Гаусса подробно (по шагам) выполняется только в учебных целях, когда нужно показать, что Вы это умеете. А чтобы решить реальную СЛАУ, лучше применить в Excel метод обратной матрицы или воспользоваться специальными программами, например, этой

Краткое описание.

  1. Решаю систему уравнений: A*X=B, где A – квадратная матрица n-го порядка, X,B – вектора
  2. К матрице A справа приписываю вектор B.

    Получаю расширенную матрицу A

  3. В дальнейшем A обозначает расширенную матрицу (n строк, n+1 столбец)
  4. Aij – обозначает элемент матрицы, находящийся на i-й строке и j-м столбце
  5. Делю 1-ю строку на A11, т е A'1j = A1j/A11 (j = 1..n+1). В результате A'11 = 1.

    A' обозначает преобразованную строку

  6. Преобразую остальные строки по формуле: A'ij = Aij – A'1j*Ai1 (i = 2..n; j = 1..n+1)
  7. В результате 1-й столбец в строках 2..

    n заполнится нулями

  8. Отметим, что все эти преобразования не нарушают правильность уравнений
  9. Аналогичные действия проводим для обнуления 2-го столбца в строках 3..n, то есть:
  10. Делю 2-ю строку на A'22, т е A''2j = A'2j/A'22 (j = 2..n+1). В результате A''22 = 1.

    A'' обозначает резельтат 2-го преобразования строки

  11. Преобразую остальные строки по формуле: A''ij = A'ij – A''2j*A'i2 (i = 3..n; j = 2..n+1)
  12. В результате 2-й столбец в строках 3..

    n заполнится нулями

  13. Аналогичные действия проводим далее
  14. В результате левые n столбцов матрицы A превращаютс в верхнюю треугольную матрицу, т е ниже главной диагонали находятся только нули (а на главной диагонали – единицы) – см Рис 1. На этом рисунке вектор B – слева, S – номер шага
  15. Затем выполняется “обратный ход”, начиная с нижней строки, из которой можно вычислить Xn = Bn/Ann, например: Х4 = 9,55741/68,6388 = 0,13924 (рис. 1)
  16. Затем можно вычислить X3 = (0,9065 – 2,40919*0,13924) = 0,57059
  17. Затем из второй строки: X2 + 2,83562*X3 + 8,17808*X4 = 2,47945 вычисляю X2, и т д

3. Метод Якоби (метод простых итераций)

Для применения метода Якоби (и метода Зейделя) необходимо, чтобы диагональные компоненты матрицы А были больше суммы остальных компонент той же строки. Заданная система не обладает таким свойством, поэтому выполняю предварительные преобразования.

Далее номер в скобках означает номер строки. Новую первую строку получаю сложением старой первой строки с другими строками, умноженными на специально подобранные коэффициенты. Записываю это в виде формулы:

(1)’ = (1) + 0,43*(2) – 0,18*(3) – 0,96*(4) (2)’ = (2) + 0,28*(1) – 1,73*(3) + 0,12*(4) (3)’ = (3) – 0,27*(1) – 0,75*(2) + 0,08*(4) (4)’ = (4) + 0,04*(1) – 6,50*(2) + 8,04*(3) Примечание: подбор коэффицентов выполнен на листе “Анализ”. Решаются системы уравнений, цель которых – обратить внедиагональные элементы в нуль. Коэффиценты – это округлённые результаты решения таких систем уравнений. Конечно, это не дело. В результате получаю систему уравнений: Для применения метода Якоби систему уравнений нужно преобразовать к виду: X = B2 + A2*X Преобразую: Далее делю каждую строку на множитель левого столбца, то есть на 16, 7, 3, 70 соответственно. Тогда матрица А2 имеет вид : А вектор В2:

Скачать

Источник: http://www.win-ni.narod.ru/exc/slau.htm

Методы решения систем линейных уравнений средствами табличного процессора MS Excel — реферат

Решение системы уравнений в Microsoft Excel

  1. Умножим полученное уравнение (4) на a21, т.е. на 1, получим уравнение (5).
  1. Вычтем  из уравнений (2) и (3) уравнение (5), получим  уравнения (6) и (7).
  1. Уравнение (6) разделим на a22, т.е. на 3/2, получим уравнение (8).
  1. Умножим уравнение (8) на a32, т.е. на 1/2, получим уравнение (9).

  1. Вычтем  из уравнения (7) уравнение (9) получим  уравнение (10).
  1. Итак, прямой ход закончен, начинаем обратный ход. Подставим (10) в уравнение (8), получим x2=2 (11).
  2. Подставим (11) и (10) в уравнение (5), получим: x1=1 (12).

Ответ:x1=1; x2=2; x3=3.

       В школьной практике, как правило, встречаются системы с двумя и тремя неизвестными, хотя, разумеется, бывают и исключения.

2. Практическая часть

       Если же говорить о программе Excel, которая является одной из более узнаваемых в обработке электронных таблиц, то без преувеличения можно утверждать, что её способности фактически неистощимы.

       Обработка текста, управление базами данных – программа так массивна, что во многих вариантах превосходит специализированные программы-редакторы либо программы баз данных. Такое обилие функций может сначала запутать, нежели вынудить использовать их на практике. Но по мере приобретения опыта начинаешь по достоинству ценить то, что границ возможностей Excel тяжело достичь.

       Программа Microsoft Excel входит в офисный пакет Microsoft Office и предназначена для подготовки и обработки электронных таблиц под управлением операционной системой Windows.

Microsoft Excel – это многофункциональный, мощный редактор электронных таблиц.

Он представляет возможность производить различные расчеты, составлять списки, сметы и что немаловажно, строить наглядные графики и диаграммы.

2.2.2. Методика построения компьютерной модели «Решение системы линейных уравнений способом подстановки» в Microsoft Excel

     Рассмотрим построение компьютерной модели решения системы уравнений на конкретном примере.

     Постановка задачи: решить систему уравнений методом подстановки

     Цель: построить компьютерную модель решения данной системы уравнений в ЭТ MS Excel.

     Исходные данные: коэффициенты a1=2, b1=4, c1=15, a2=5, b2=3, c2=10.

     Результат: искомые числа х и у.

     Формализация:

  1. Выразим в первой уравнении неизвестную у через х: 4у=15–2х; у=3,75–0,5х.
  2. Подставим полученное выражение в первое уравнение и решим его как линейное уравнение неизвестной х: 5х+3(3,75–0,5х)=10; 3,5х+11,25=10; 3,5х= –1,25; х= –0,36.
  3. Сделаем подстановку найденного значения переменной и вычислим значение второй переменной у=3,75–0,5(–0,36)=3,93.
  4. Запишем ответ: х= –0,36, у=3,93.

     Построение компьютерной модели:

  1. В ячейку А1 введем заголовок Решение системы линейных уравнений с двумя неизвестными способом подстановки.
  2. Объединим ячейки А1:R3 и расположим заголовок по центру (кнопка ).
  3. В ячейки В5, Е5, В6, Е6, Н5, Н6 введем коэффициенты и свободные члены уравнений.
  4. Объединим ячейки D8:F8 и введем Решение.
  5. В ячейку В9 вводим =Е5, Е9 вводим =Н5, G9 вводим =В5.
  6. В ячейки В10, В13 и В15 вводим =В6, в ячейки Е10, Е13 и Е15 вводим =Е6, в ячейки Н10, Н13, L10 и G17 вводим =Н6.
  7. В ячейку Е12 вводим =E9/B9, G12 вводим =G9/B9.
  8. В ячейки G15 вводим =Е12, I15 вводим =G12.
  9. В ячейку В17 вводим =B15–E15*I15, в ячейку Е17 вводим =E15*G15.
  10. В ячейку В18 вводим =B17, в ячейку Е18 вводим =G17–E17.
  11. В ячейку С19 вводим =ЕСЛИ(НЕ(B18=0);”х“;””).
  12. В ячейку D19 вводим =ЕСЛИ(НЕ(B18=0);”=”;””).
  13. В ячейку Е19 вводим =ЕСЛИ(НЕ(B18=0);E18/B18;””).
  14. В ячейку Н19 вводим =ЕСЛИ(НЕ(B18=0);”у=”;””).
  15. В ячейку I19 вводим =ЕСЛИ(НЕ(B18=0);E12-G12*E19;””).
  16. Объединим ячейки D21:F21 и введем Ответ.
  17. В ячейку F21 вводим =ЕСЛИ(И(B18=0;E18=0);”Бесконечно много решений”;ЕСЛИ(И(B18=0;E180);”Решений нет”;””)).
  18. В ячейку E22 вводим =ЕСЛИ(НЕ(B18=0);”х=”;””).
  19. В ячейку E23 вводим =ЕСЛИ(НЕ(B18=0);”y=”;””).
  20. В ячейку F22 вводим =ЕСЛИ(НЕ(B18=0);E19;””).
  21. В ячейку F23 вводим =ЕСЛИ(НЕ(B18=0);I19;””).
  22. Обозначения переменных х и у и знаки арифметических операций и скобки вводим с клавиатуры (перед знаками арифметических операций +, –, = ставим пробел).

     Компьютерный эксперимент: подставляя в систему уравнений различные коэффициенты, можно убедиться, что построенная модель работает для всех случаев: есть единственное решение; решений системы уравнений нет; решений бесконечно много.

2.2.3. Методика построения компьютерной модели «Решение системы линейных уравнений способом сложения» в Microsoft Excel

     Рассмотрим построение компьютерной модели решения системы уравнений на конкретном примере.

     Постановка задачи: решить систему уравнений способом сложения

     Цель: построить компьютерную модель решения данной системы уравнений в ЭТ MS Excel.

     Исходные данные: коэффициенты a1=2, b1=4, c1=15, a2=5, b2=3, c2=10.

     Результат: искомые числа х и у.

     Формализация:

  1. Уравнять модули коэффициентов при переменной х.
  1. Сложить почленно уравнения системы. Решить новое уравнение 14у=55 и найти значение одной переменной у=55/14=3,93.
  2. Подставить значение найденной переменной в старое уравнение и найти значение другой переменной 2х+4×3,93=15; х=(15–4×3,93)/2= –0,36.
  3. Запишем ответ: х= –0,36 , у=3,93.

     Построение компьютерной модели:

  1. В ячейку А1 введем заголовок Решение системы линейных уравнений с двумя неизвестными способом подстановки.
  2. Объединим ячейки А1:R3 и расположим заголовок по центру (кнопка ).
  3. В ячейки В5, Е5, В6, Е6, Н5, Н6 введем коэффициенты и свободные члены уравнений.
  4. В ячейку G8 введем Решение.
  5. В ячейку В9 вводим =B5*B6, Е9 вводим =E5*B6, H9 вводим =H5*B6.
  6. В ячейку В10 вводим = –B6*B5, в Е10 вводим = –E6*B5, в H10 вводим = –H6*B5.
  7. В ячейку E12 вводим =E9+E10, в Н12 вводим =H9+H10.
  8. В ячейку F14 вводим =ЕСЛИ(E12=0;””;”у“).
  9. В ячейку G14 вводим =ЕСЛИ(E12=0;””;”=”).
  10. В ячейку H14 вводим =ЕСЛИ(E12=0;””;H12/E12).
  11. В ячейку F15 вводим =ЕСЛИ(E12=0;””;”x“).
  12. В ячейку G15 вводим =ЕСЛИ(E12=0;””;”=”).
  13. В ячейку H14 вводим =ЕСЛИ(E12=0;””;(H5–E5*H14)/B5).
  14. Объединим ячейки D18:F18 и введем Ответ.
  15. В ячейку F18 вводим =ЕСЛИ(И(E12=0;H12=0);”Бесконечно много решений”;ЕСЛИ(И(E12=0;H120);”Решений нет”;””)).
  16. Ячейки F18:J18 объединяем.
  17. В ячейку F19 вводим =ЕСЛИ(E12=0;””;”х=”).
  18. В ячейку G19 вводим =ЕСЛИ(E12=0;””;H15).
  19. В ячейку I19 вводим =ЕСЛИ(E12=0;””;”у=”).
  20. В ячейку J19 вводим =ЕСЛИ(E12=0;””;H14).

     Компьютерный эксперимент: подставляя в систему уравнений различные коэффициенты, можно убедиться, что построенная нами модель работает для всех случаев: есть единственное решение; решений системы уравнений нет; решений бесконечно много.

2.2.4. Методика построения компьютерной модели «Решение системы линейных уравнений методом Крамера» в Microsoft Excel

     Рассмотрим построение компьютерной модели решения системы уравнений на конкретном примере.

     Постановка задачи: решить систему уравнений методом Крамера

     Цель: построить компьютерную модель решения данной системы уравнений в ЭТ MS Excel.

     Исходные данные: коэффициенты a1=2, b1=4, c1=15, a2=5, b2=3, c2=10.

     Результат: искомые числа х, у и z.

     Формализация: Построим матрицу А системы уравнений: .

     Найдем основной определитель матрицы А:

.

     Найдем дополнительные определители матрицы А

,

.

     Найдем х=D/Dх=5/(–14)= –0,36 и у=D/Dу= –55/(–14)=3,93.

     Построение компьютерной модели:

  1. В ячейку А1 введем заголовок Решение системы линейных уравнений с двумя неизвестными методом Крамера.
  2. Объединим ячейки А1:R3 и расположим заголовок по центру (кнопка ).
  3. В ячейки В5, Е5, В6, Е6, Н5, Н6 введем коэффициенты и свободные члены уравнений.
  4. В ячейку D9 введем Решение.
  5. В ячейку C11 введем D (Вставка/Символ). Объединим С11:С12. Аналогично в ячейку С14 вводим Dх, в ячейку С17 вводим Dу.
  6. Объединим ячейки D11:D12, D14:D15, D17:D18 и G11:G12, G14:G15, G17:G18 введем D в эти ячейки знак =.
  7. В ячейку E11 введем =В5, в ячейку Е12 введем =В7, в ячейку F11 введем =Е5, в ячейку F12 введем Е7, в ячейку Н11 введем =МОПРЕД(E11:F12).
  8. Ячейки Н11:Н12 объединим.
  9. В ячейку E14 введем =Н5, в ячейку Е15 введем =Н7, в ячейку F14 введем =Е5, в ячейку F15 введем Е7, в ячейку Н14 введем =МОПРЕД(E14:F15).
  10. В ячейку E17 введем =Е5, в ячейку Е18 введем =Е7, в ячейку F17 введем =Н5, в ячейку F18  введем Н7, в ячейку Н17 введем =МОПРЕД(E17:F18).
  11. Ячейки Н14:Н15 и Н17:Н18 объединим.
  12. Объединим ячейки D20:F20 и введем Ответ.
  13. В ячейку Е20 вводим =ЕСЛИ(И($H$11=0;$H$14=0;$H$17=0);”Бесконечно много решений”;ЕСЛИ(И($H$11=0;ИЛИ($H$140;$H$170));”Нет решений”;””)).
  14. В ячейку Е21 вводим =ЕСЛИ($H$11=0;””;”x“).
  15. В ячейку Е23 вводим =ЕСЛИ($H$11=0;””;”y“).
  16. В ячейку F21 и F23 вводим =ЕСЛИ($H$11=0;””;”=”).
  17. В ячейку G21 вводим =ЕСЛИ($H$11=0;””;$H$14/$H$11).
  18. В ячейку G23 вводим =ЕСЛИ($H$11=0;””;$H$17/$H$11).

     Компьютерный эксперимент: подставляя в систему уравнений различные коэффициенты, можно убедиться, что построенная модель работает для всех случаев: есть единственное решение; решений системы уравнений нет; решений бесконечно много.

2.2.5. Методика построения компьютерной модели «Решение системы линейных уравнений методом Гаусса» в Microsoft Excel

     Рассмотрим построение компьютерной модели решения системы уравнений на конкретном примере.

     Постановка задачи: решить систему уравнений Методом Гаусса

     Цель: построить компьютерную модель решения данной системы уравнений в ЭТ MS Excel.

     Исходные данные: коэффициенты a1=2, b1=4, c1=2, a2=3, b2=3, c2=5, a3=6, b3=8, c3=5, d1=5, d2=10, d3=15.

     Результат: искомые числа х, у и z.

     Формализация: преобразовывая уравнения, приведем систему к ступенчатому виду.

→→.

     Из последнего уравнения находим z= –40/–44=0,91

     Подставляя значение z во второе уравнение находим у=(–5+4×0,91)/6= –0,23.

     Подставляя значение z и у в первое уравнение находим х=(5–2×0,91–4×(–0,23))/2=2,05.

     Построение компьютерной модели:

  1. В ячейку А1 введем заголовок Решение системы линейных уравнений с тремя неизвестными методом Гаусса.
  2. Объединим ячейки А1:О2 и расположим заголовок по центру (кнопка ).
  3. В ячейки В4, В6, В8, Е4, Е6, Е8, Н4, Н6, Н8, К4, К6, К8 введем коэффициенты и свободные члены уравнений.
  4. В ячейку С10 введем Решение.
  5. В ячейку В11 и В18 введем =В4, в ячейку Е11 и Е18 введем =Е4, в ячейку Н11 и Н18 введем =Н4, в ячейку К11 и К18 введем К4.
  6. В ячейку Е13 введем =ЕСЛИ(ИЛИ(И(B4>0;B6>0);И(B40);И(B40);И(B40);И(B40);И(B40);И(B40);И(E130);И(E13

Источник: http://turboreferat.ru/information/metody-resheniya-sistem-linejnyh-uravnenij/59713-304648-page2.html

Поделиться:
Нет комментариев

    Добавить комментарий

    Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.